summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/man-db/man-db-9999.ebuild')
-rw-r--r--sys-apps/man-db/man-db-9999.ebuild32
1 files changed, 31 insertions, 1 deletions
diff --git a/sys-apps/man-db/man-db-9999.ebuild b/sys-apps/man-db/man-db-9999.ebuild
index 4d2bfc884fe9..0d01ad57258f 100644
--- a/sys-apps/man-db/man-db-9999.ebuild
+++ b/sys-apps/man-db/man-db-9999.ebuild
@@ -8,7 +8,7 @@ inherit systemd
DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
HOMEPAGE="http://www.nongnu.org/man-db/"
if [[ "${PV}" = 9999* ]] ; then
- inherit git-r3
+ inherit autotools git-r3
EGIT_REPO_URI="https://git.savannah.gnu.org/git/man-db.git"
else
SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
@@ -52,6 +52,36 @@ pkg_setup() {
fi
}
+src_unpack() {
+ if [[ "${PV}" == *9999 ]] ; then
+ git-r3_src_unpack
+
+ # We need to mess with gnulib :-/
+ EGIT_REPO_URI="https://git.savannah.gnu.org/r/gnulib.git" \
+ EGIT_CHECKOUT_DIR="${WORKDIR}/gnulib" \
+ git-r3_src_unpack
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+ if [[ "${PV}" == *9999 ]] ; then
+ local bootstrap_opts=(
+ --gnulib-srcdir=../gnulib
+ --no-bootstrap-sync
+ --copy
+ --no-git
+ )
+ AUTORECONF="/bin/true" \
+ LIBTOOLIZE="/bin/true" \
+ sh ./bootstrap "${bootstrap_opts[@]}" || die
+
+ eautoreconf
+ fi
+}
+
src_configure() {
export ac_cv_lib_z_gzopen=$(usex zlib)
local myeconfargs=(