summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 6bf7ded639ba..dea79c65bd1c 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
fi
LICENSE="BSD-2"
@@ -182,12 +182,12 @@ pkg_postinst() {
# Added for 0.35.
if use kernel_linux && [[ ! -h "${EROOT}"/lib ]]; then
- if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
- cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"/lib
+ if [[ -d "${EROOT}/$(get_libdir)"/rc ]]; then
+ cp -RPp "${EROOT}/$(get_libdir)/rc" "${EROOT}"/lib
fi
elif ! use kernel_linux; then
- if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
- cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"/lib
+ if [[ -d "${EROOT}/$(get_libdir)"/rc ]]; then
+ cp -RPp "${EROOT}/$(get_libdir)/rc" "${EROOT}"/lib
fi
fi