summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pick/pick-2.0.1.ebuild')
-rw-r--r--sys-apps/pick/pick-2.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/pick/pick-2.0.1.ebuild b/sys-apps/pick/pick-2.0.1.ebuild
new file mode 100644
index 000000000000..88c100aa3408
--- /dev/null
+++ b/sys-apps/pick/pick-2.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="a fuzzy search tool for the command-line"
+HOMEPAGE="https://github.com/calleerlandsson/pick"
+SRC_URI="https://github.com/calleerlandsson/pick/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.0-cflags.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}