summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/Manifest4
-rw-r--r--sys-apps/policycoreutils/policycoreutils-3.5.ebuild (renamed from sys-apps/policycoreutils/policycoreutils-3.4.ebuild)11
-rw-r--r--sys-apps/policycoreutils/policycoreutils-3.6.ebuild (renamed from sys-apps/policycoreutils/policycoreutils-3.3.ebuild)28
-rw-r--r--sys-apps/policycoreutils/policycoreutils-9999.ebuild13
4 files changed, 36 insertions, 20 deletions
diff --git a/sys-apps/policycoreutils/Manifest b/sys-apps/policycoreutils/Manifest
index 8902061e7b5e..6983b77d03e7 100644
--- a/sys-apps/policycoreutils/Manifest
+++ b/sys-apps/policycoreutils/Manifest
@@ -1,3 +1,3 @@
-DIST policycoreutils-3.3.tar.gz 2818092 BLAKE2B 0ed9f128a774176ebadb71f448af8dee8c616a706314783b646869e7ea91892e358d5bb03e3aece3d0e6dc3203852e4e2925482727df1e5c71e075236ee43e5c SHA512 db658990355f99a8e43f53d20cc67bf9e557b0a7837d1927c80f325b7f93ad47876382278a980b818484d6e31712a9b03e279f947ebc88c4be60a9f395607f98
-DIST policycoreutils-3.4.tar.gz 771435 BLAKE2B 53654ad8f17c8e539c7821ddcc4f40dde1aa214943b5f2876efbfd8e10c90747d21c1530df3d53e51677159026a70691db6282f3bedc79739673380e053f74a2 SHA512 ded0d6fb5e3f165a893ee42411ac82616ddf37a02acaca6a8437b8f10ea12e5594bbd7bc7e3ead12df00c018078950f3fbe55604c41b0554257c4ca18f55ebb6
+DIST policycoreutils-3.5.tar.gz 775639 BLAKE2B 777b8564484e89385db7a184c4cad9a99aabf1fd1ac41abd5826c7e6ad29118ae9d6f0d0fd968b6ced87f2f04bc6d7cd207b67428151522915367f656fb8d3f8 SHA512 7978ef6b7a278c6384c9b397734d03c4932c8aefecceaa1e6a1345be27b253dbe276fdcd219ce83ad732c6ed55d53bbc3254e39bccadd67d2cd1152a14749444
+DIST policycoreutils-3.6.tar.gz 755682 BLAKE2B a8b180c8006989192d152651dcfa51856956780bfe1139cc1dc0162eb66ba1eef4f7d64f68a48479572b02e2e97a68c7082722a745d22a9453e8378373319e3c SHA512 e1f32e6e0310b879a5aadab157b103314a61bf3b8fd59c1212d701fbf39900e3b9a0b727338988103d784a7e505355a871ba519dd91520b135a3b9dae40bf1b0
DIST policycoreutils-extra-1.37.tar.bz2 8809 BLAKE2B a7f6122c2e27f54b018174e962bd7f4c14af04e09bbb5300bde6967ea7f2dc5cd03b5787919a4e7f5288bcbc6747922962b5bd3b588ab1e3a035fbff4910d8f5 SHA512 0a85cd7cf279256b5e1927f9dfdd89626a1c8b77b0aeb62b496e7e8d1dccbaa315e39f9308fb2df7270f0bc1c10787b19990e7365cad74b47b61e30394c8b23f
diff --git a/sys-apps/policycoreutils/policycoreutils-3.4.ebuild b/sys-apps/policycoreutils/policycoreutils-3.5.ebuild
index eb49d7350f93..5d45077b38c6 100644
--- a/sys-apps/policycoreutils/policycoreutils-3.4.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-3.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="xml(+)"
inherit multilib python-r1 toolchain-funcs bash-completion-r1
@@ -139,7 +139,12 @@ src_install() {
rm -fR "${D}/etc/rc.d" || die
# compatibility symlinks
- use split-usr && dosym ../../sbin/setfiles /usr/sbin/setfiles
+ if use split-usr; then
+ dosym ../../sbin/setfiles /usr/sbin/setfiles
+ else
+ # remove sestatus symlink
+ rm -f "${D}"/usr/sbin/sestatus || die
+ fi
bashcomp_alias setsebool getsebool
diff --git a/sys-apps/policycoreutils/policycoreutils-3.3.ebuild b/sys-apps/policycoreutils/policycoreutils-3.6.ebuild
index 456189b1aac5..e2527faa689b 100644
--- a/sys-apps/policycoreutils/policycoreutils-3.3.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-3.6.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
-inherit multilib python-r1 toolchain-funcs bash-completion-r1
+inherit python-r1 toolchain-funcs bash-completion-r1
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
EXTRAS_VER="1.37"
-IUSE="audit pam split-usr"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
DESCRIPTION="SELinux core utilities"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
@@ -19,20 +18,22 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
SRC_URI="https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
- S1="${WORKDIR}/${PN}"
+ S1="${WORKDIR}/${P}/${PN}"
S2="${WORKDIR}/policycoreutils-extra"
S="${S1}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz
https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
KEYWORDS="amd64 arm arm64 ~mips x86"
- S1="${WORKDIR}/${P}"
+ S1="${WORKDIR}/${MY_P}"
S2="${WORKDIR}/policycoreutils-extra"
S="${S1}"
fi
LICENSE="GPL-2"
SLOT="0"
+IUSE="audit pam split-usr"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=">=sys-libs/libselinux-${PV}:=[python,${PYTHON_USEDEP}]
>=sys-libs/libsemanage-${PV}:=[python(+),${PYTHON_USEDEP}]
@@ -138,7 +139,12 @@ src_install() {
rm -fR "${D}/etc/rc.d" || die
# compatibility symlinks
- use split-usr && dosym ../../sbin/setfiles /usr/sbin/setfiles
+ if use split-usr; then
+ dosym ../../sbin/setfiles /usr/sbin/setfiles
+ else
+ # remove sestatus symlink
+ rm -f "${D}"/usr/sbin/sestatus || die
+ fi
bashcomp_alias setsebool getsebool
diff --git a/sys-apps/policycoreutils/policycoreutils-9999.ebuild b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
index 1ac0b78acdaf..b8625ff49cd8 100644
--- a/sys-apps/policycoreutils/policycoreutils-9999.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
-inherit multilib python-r1 toolchain-funcs bash-completion-r1
+inherit python-r1 toolchain-funcs bash-completion-r1
MY_PV="${PV//_/-}"
MY_P="${PN}-${MY_PV}"
@@ -139,7 +139,12 @@ src_install() {
rm -fR "${D}/etc/rc.d" || die
# compatibility symlinks
- use split-usr && dosym ../../sbin/setfiles /usr/sbin/setfiles
+ if use split-usr; then
+ dosym ../../sbin/setfiles /usr/sbin/setfiles
+ else
+ # remove sestatus symlink
+ rm -f "${D}"/usr/sbin/sestatus || die
+ fi
bashcomp_alias setsebool getsebool