summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/portage/portage-2.3.40.ebuild')
-rw-r--r--sys-apps/portage/portage-2.3.40.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-2.3.40.ebuild b/sys-apps/portage/portage-2.3.40.ebuild
index 813b4a058fe1..a0135a2bd759 100644
--- a/sys-apps/portage/portage-2.3.40.ebuild
+++ b/sys-apps/portage/portage-2.3.40.ebuild
@@ -10,7 +10,7 @@ PYTHON_COMPAT=(
)
PYTHON_REQ_USE='bzip2(+),threads(+)'
-inherit distutils-r1 systemd
+inherit distutils-r1 eutils systemd
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -85,7 +85,8 @@ prefix_src_archives() {
TARBALL_PV=${PV}
SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
- $(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)"
+ $(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)
+ https://github.com/gentoo/portage/commit/345256c2d439c5ab580e4226f227db2819883d40.patch -> ${P}-bug-657360-345256c2d439.patch"
pkg_setup() {
use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
@@ -94,6 +95,8 @@ pkg_setup() {
python_prepare_all() {
distutils-r1_python_prepare_all
+ epatch "${DISTDIR}/${P}-bug-657360-345256c2d439.patch"
+
# apply d07a47ff3c06
sed -i 's:("--dynamic-deps", "y") != "n"$:\0 and "--nodeps" not in myopts:' \
pym/_emerge/create_depgraph_params.py || die