summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild')
-rw-r--r--sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild
new file mode 100644
index 000000000000..a7609810e962
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Script to rescan the SCSI bus without rebooting"
+HOMEPAGE="http://www.garloff.de/kurt/linux/"
+SCRIPT_NAME="${PN}.sh"
+SRC_NAME="${SCRIPT_NAME}-${PV}"
+SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=">=sys-apps/sg3_utils-1.24
+ virtual/modutils
+ app-shells/bash"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
+}
+
+src_install() {
+ into /usr
+ dosbin ${SCRIPT_NAME}
+ # Some scripts look for this without the trailing .sh
+ # Some look for it with the trailing .sh, so have a symlink
+ dosym ${SCRIPT_NAME} /usr/sbin/${PN}
+}