summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/thunderbolt-software-user-space')
-rw-r--r--sys-apps/thunderbolt-software-user-space/files/thunderbolt-software-user-space-0.9.3-cmake.patch15
-rw-r--r--sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild2
2 files changed, 17 insertions, 0 deletions
diff --git a/sys-apps/thunderbolt-software-user-space/files/thunderbolt-software-user-space-0.9.3-cmake.patch b/sys-apps/thunderbolt-software-user-space/files/thunderbolt-software-user-space-0.9.3-cmake.patch
new file mode 100644
index 000000000000..68d50bb282c5
--- /dev/null
+++ b/sys-apps/thunderbolt-software-user-space/files/thunderbolt-software-user-space-0.9.3-cmake.patch
@@ -0,0 +1,15 @@
+'For DEB', so why do they install it by default?
+Only redundant here, and a minor QA offence.
+
+--- a/CMakeLists.txt 2018-02-14 09:42:31.000000000 +0100
++++ b/CMakeLists.txt 2019-09-30 23:47:11.529985366 +0200
+@@ -102,9 +102,4 @@
+ set(CPACK_PACKAGE_FILE_NAME
+ "${CPACK_PACKAGE_NAME}-${CPACK_PACKAGE_VERSION}-${CPACK_PACKAGE_RELEASE}.${CMAKE_SYSTEM_PROCESSOR}")
+
+-# For DEB
+-install(FILES ${CPACK_RESOURCE_FILE_LICENSE}
+- DESTINATION share/doc/${CPACK_PACKAGE_NAME}
+- RENAME copyright)
+-
+ include(CPack)
diff --git a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
index e8db90238f7f..da1c56e10ab8 100644
--- a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
+++ b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3-r1.ebuild
@@ -18,6 +18,8 @@ IUSE=""
DEPEND="dev-libs/boost:="
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
pkg_pretend() {
CONFIG_CHECK="THUNDERBOLT"
ERROR_THUNDERBOLT="This program talks to the thunderbolt kernel driver, so please enable it."