summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ucspi-unix/files')
-rw-r--r--sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch19
-rw-r--r--sys-apps/ucspi-unix/files/ucspi-unix-0.36-include-sys_socket.h.patch11
-rw-r--r--sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch33
3 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch b/sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch
new file mode 100644
index 000000000000..94fc07cb0022
--- /dev/null
+++ b/sys-apps/ucspi-unix/files/ucspi-unix-0.36-fix-parallel-build.patch
@@ -0,0 +1,19 @@
+--- Makefile.orig 2010-01-14 14:42:14.000000000 +0100
++++ Makefile 2010-01-14 14:42:42.000000000 +0100
+@@ -41,14 +41,14 @@
+ ./load insthier -linstaller
+ mv insthier installer
+
+-instcheck: load insthier.o
++instcheck: load insthier.o installer instshow
+ ./load insthier -linstcheck
+ mv insthier instcheck
+
+ insthier.o: compile insthier.c conf_bin.c conf_man.c
+ ./compile insthier.c
+
+-instshow: load insthier.o
++instshow: load insthier.o installer
+ ./load insthier -linstshow
+ mv insthier instshow
+
diff --git a/sys-apps/ucspi-unix/files/ucspi-unix-0.36-include-sys_socket.h.patch b/sys-apps/ucspi-unix/files/ucspi-unix-0.36-include-sys_socket.h.patch
new file mode 100644
index 000000000000..0d96450911c5
--- /dev/null
+++ b/sys-apps/ucspi-unix/files/ucspi-unix-0.36-include-sys_socket.h.patch
@@ -0,0 +1,11 @@
+diff -Naur ucspi-unix-0.36.orig/env.c ucspi-unix-0.36/env.c
+--- ucspi-unix-0.36.orig/env.c 2002-06-10 23:12:06.000000000 +0200
++++ ucspi-unix-0.36/env.c 2008-11-06 16:31:09.000000000 +0100
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <sysdeps.h>
++#include <sys/socket.h>
+
+ extern const char* utoa(unsigned long);
+
diff --git a/sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch b/sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch
new file mode 100644
index 000000000000..fa360e53c1f1
--- /dev/null
+++ b/sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch
@@ -0,0 +1,33 @@
+--- ucspi-unix-0.36/Makefile.orig 2003-12-26 18:50:34.000000000 -0500
++++ ucspi-unix-0.36/Makefile 2003-12-26 18:50:56.000000000 -0500
+@@ -18,18 +18,18 @@
+ ( echo '#!/bin/sh'; \
+ echo 'source=$$1; shift'; \
+ echo 'base=`echo "$$source" | sed -e s:\\\\.c$$::`'; \
+- echo exec `head -1 conf-cc` '-I. -o $${base}.o -c $$source $${1+"$$@"}'; \
++ echo exec `head -n 1 conf-cc` '-I. -o $${base}.o -c $$source $${1+"$$@"}'; \
+ ) >compile
+ chmod 755 compile
+
+ conf_bin.c: conf-bin
+- head -1 conf-bin | \
++ head -n 1 conf-bin | \
+ sed -e 's/"/\\"/g' \
+ -e 's/^/const char conf_bin[] = "/' \
+ -e 's/$$/";/' >conf_bin.c
+
+ conf_man.c: conf-man
+- head -1 conf-man | \
++ head -n 1 conf-man | \
+ sed -e 's/"/\\"/g' \
+ -e 's/^/const char conf_man[] = "/' \
+ -e 's/$$/";/' >conf_man.c
+@@ -55,7 +55,7 @@
+ load: conf-ld
+ ( echo '#!/bin/sh';\
+ echo 'main="$$1"; shift';\
+- echo exec `head -1 conf-ld` '-o "$$main" "$$main.o" $${1+"$$@"}' -lsysdeps;\
++ echo exec `head -n 1 conf-ld` '-o "$$main" "$$main.o" $${1+"$$@"}' -lsysdeps;\
+ ) >load
+ chmod 755 load
+