summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/usbmon/usbmon-6-r1.ebuild')
-rw-r--r--sys-apps/usbmon/usbmon-6-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/usbmon/usbmon-6-r1.ebuild b/sys-apps/usbmon/usbmon-6-r1.ebuild
new file mode 100644
index 000000000000..00de00180335
--- /dev/null
+++ b/sys-apps/usbmon/usbmon-6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Userland for USB monitoring framework"
+HOMEPAGE="http://people.redhat.com/zaitcev/linux/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="GPL-2" # GPL-2 only
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="!=sys-apps/usbutils-0.72-r2"
+
+src_prepare() {
+ sed \
+ -e '/CFLAGS =/s, = , \+= ,g' \
+ -e 's:-O2::g' \
+ -i "${S}"/Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dosbin ${PN}
+ doman ${PN}.8
+ dodoc README
+}