summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/usbredir/usbredir-9999.ebuild')
-rw-r--r--sys-apps/usbredir/usbredir-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/usbredir/usbredir-9999.ebuild b/sys-apps/usbredir/usbredir-9999.ebuild
new file mode 100644
index 000000000000..104622ce0aa9
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic autotools git-2
+
+DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="http://spice-space.org/page/UsbRedir"
+EGIT_REPO_URI="http://anongit.freedesktop.org/git/spice/usbredir.git"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="ChangeLog README* TODO *.txt"
+
+EGIT_BOOTSTRAP="eautoreconf"
+
+src_configure() {
+ # http://bugs.freedesktop.org/show_bug.cgi?id=54643
+ append-cflags -Wno-error
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ # noinst_PROGRAMS
+ dobin usbredirtestclient/usbredirtestclient
+}