summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xinetd/files')
-rw-r--r--sys-apps/xinetd/files/xinetd-2.3.14-DESTDIR.patch27
-rw-r--r--sys-apps/xinetd/files/xinetd-2.3.14-config.patch9
-rw-r--r--sys-apps/xinetd/files/xinetd-2.3.14-install-contrib.patch24
-rw-r--r--sys-apps/xinetd/files/xinetd.confd3
-rw-r--r--sys-apps/xinetd/files/xinetd.rc633
-rw-r--r--sys-apps/xinetd/files/xinetd.service10
6 files changed, 106 insertions, 0 deletions
diff --git a/sys-apps/xinetd/files/xinetd-2.3.14-DESTDIR.patch b/sys-apps/xinetd/files/xinetd-2.3.14-DESTDIR.patch
new file mode 100644
index 000000000000..2ebdf4c4f1b0
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd-2.3.14-DESTDIR.patch
@@ -0,0 +1,27 @@
+--- Makefile.in.orig 2005-10-29 22:08:54.000000000 -0400
++++ Makefile.in 2005-10-29 22:09:32.000000000 -0400
+@@ -75,15 +75,15 @@
+
+ install: build
+ for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
+- test -d $$i || mkdir -p $$i ; done
+- $(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
+- $(INSTALL_CMD) -m 755 xinetd/itox $(DAEMONDIR)
+- $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DAEMONDIR)
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(MANDIR)/man5/xinetd.conf.5
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(MANDIR)/man8/xinetd.log.8
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(MANDIR)/man8/xinetd.8
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(MANDIR)/man8/itox.8
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(MANDIR)/man8/xconv.pl.8
++ test -d $(DESTDIR)$$i || mkdir -p $(DESTDIR)$$i ; done
++ $(INSTALL_CMD) -m 755 xinetd/xinetd $(DESTDIR)$(DAEMONDIR)
++ $(INSTALL_CMD) -m 755 xinetd/itox $(DESTDIR)$(DAEMONDIR)
++ $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DESTDIR)$(DAEMONDIR)
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(DESTDIR)$(MANDIR)/man8/xinetd.8
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(DESTDIR)$(MANDIR)/man8/itox.8
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(DESTDIR)$(MANDIR)/man8/xconv.pl.8
+ @echo "You must put your xinetd.conf in /etc/xinetd.conf"
+ @echo "There is a sample config file in xinetd/sample.conf and you can"
+ @echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"
diff --git a/sys-apps/xinetd/files/xinetd-2.3.14-config.patch b/sys-apps/xinetd/files/xinetd-2.3.14-config.patch
new file mode 100644
index 000000000000..c368dea56e1b
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd-2.3.14-config.patch
@@ -0,0 +1,9 @@
+--- contrib/xinetd.conf
++++ contrib/xinetd.conf
+@@ -22,5 +22,5 @@
+ #
+ # no_access =
+-# only_from =
++ only_from = localhost
+ # max_load = 0
+ cps = 50 10
diff --git a/sys-apps/xinetd/files/xinetd-2.3.14-install-contrib.patch b/sys-apps/xinetd/files/xinetd-2.3.14-install-contrib.patch
new file mode 100644
index 000000000000..c1717e43902f
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd-2.3.14-install-contrib.patch
@@ -0,0 +1,24 @@
+--- xinetd-2.3.14/Makefile.in
++++ xinetd-2.3.14/Makefile.in
+@@ -9,6 +9,7 @@
+ DESTDIR =
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++ETCDIR = @sysconfdir@
+ DAEMONDIR = @sbindir@
+ MANDIR = @mandir@
+ topdir = @top_srcdir@
+@@ -97,7 +98,12 @@
+ rm -f $(MANDIR)/man8/xinetd.log.8
+ rm -f $(MANDIR)/man8/xinetd.8
+ rm -f $(MANDIR)/man8/itox.8
+-
++
++install-contrib:
++ test -d $(DESTDIR)$(ETCDIR)/xinetd.d || mkdir -p $(DESTDIR)$(ETCDIR)/xinetd.d
++ $(INSTALL_CMD) -m 644 contrib/xinetd.conf $(DESTDIR)$(ETCDIR)
++ $(INSTALL_CMD) -m 644 contrib/xinetd.d/* $(DESTDIR)$(ETCDIR)/xinetd.d
++
+ distclean: clean
+ rm -f config.cache config.log Makefile config.status xinetd/itox
+ rm -f config.h @srcdir@/libs/include/* @srcdir@/libs/man/*
diff --git a/sys-apps/xinetd/files/xinetd.confd b/sys-apps/xinetd/files/xinetd.confd
new file mode 100644
index 000000000000..ae211f3d8fcc
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd.confd
@@ -0,0 +1,3 @@
+# /etc/conf.d/xinetd: config file for /etc/init.d/xinetd
+
+XINETD_OPTS="-stayalive -reuse"
diff --git a/sys-apps/xinetd/files/xinetd.rc6 b/sys-apps/xinetd/files/xinetd.rc6
new file mode 100644
index 000000000000..57cee363f869
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd.rc6
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload dump check"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting xinetd"
+ start-stop-daemon --start --exec /usr/sbin/xinetd -- \
+ -pidfile /var/run/xinetd.pid ${XINETD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping xinetd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/xinetd.pid
+ eend $?
+}
+
+do_sig() {
+ local sig=$1 ; shift
+ ebegin "$*"
+ start-stop-daemon --signal ${sig} --pidfile /var/run/xinetd.pid
+ eend $?
+}
+reload() { do_sig HUP "Reloading configuration" ; }
+dump() { do_sig USR1 "Dumping configuration" ; }
+check() { do_sig IOT "Performing Consistency Check" ; }
diff --git a/sys-apps/xinetd/files/xinetd.service b/sys-apps/xinetd/files/xinetd.service
new file mode 100644
index 000000000000..c6f6271fd97b
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=A secure replacement for inetd
+After=network.target
+
+[Service]
+ExecStart=/usr/sbin/xinetd -dontfork
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target