summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_mount/pam_mount-2.17.ebuild')
-rw-r--r--sys-auth/pam_mount/pam_mount-2.17.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-auth/pam_mount/pam_mount-2.17.ebuild b/sys-auth/pam_mount/pam_mount-2.17.ebuild
deleted file mode 100644
index 5e97bda985c..00000000000
--- a/sys-auth/pam_mount/pam_mount-2.17.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A PAM module that can mount volumes for a user session"
-HOMEPAGE="http://pam-mount.sourceforge.net"
-SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE="crypt ssl selinux"
-
-DEPEND="
- >=sys-libs/pam-0.99
- >=sys-libs/libhx-3.12.1:=
- >=sys-apps/util-linux-2.20:=
- >=dev-libs/libxml2-2.6:=
- >=dev-libs/libpcre-7:=
- crypt? ( >=sys-fs/cryptsetup-1.1.0:= )
- ssl? ( dev-libs/openssl:0= )
- selinux? ( sys-libs/libselinux )"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/pam_mount-2.16-remove-obsolete-openssl-api.patch
-)
-
-src_configure() {
- econf --with-slibdir="/$(get_libdir)" \
- $(use_with crypt cryptsetup) \
- $(use_with ssl crypto) \
- $(use_with selinux)
-}
-
-src_install() {
- default
- use selinux || rm -r "${D}"/etc/selinux
- dodoc doc/*.txt
-
- # Remove unused nonstandard run-dir, current version uses
- # FHS-compatible /run, but has leftover mkdir from old version
- rm -r "${D}/var/lib"
-
- find "${ED}" -name '*.la' -delete || die
-}