summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_skey')
-rw-r--r--sys-auth/pam_skey/Manifest2
-rw-r--r--sys-auth/pam_skey/metadata.xml11
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild56
3 files changed, 69 insertions, 0 deletions
diff --git a/sys-auth/pam_skey/Manifest b/sys-auth/pam_skey/Manifest
new file mode 100644
index 000000000000..c08d83cf4b4b
--- /dev/null
+++ b/sys-auth/pam_skey/Manifest
@@ -0,0 +1,2 @@
+DIST pam_skey-1.1.5-patches-6.tar.xz 9264 SHA256 a1e3f43a36cb570e0690394647912c7d51bb335326e1a74ea4f97cdf8c62854d SHA512 c777ed094efe9cbfb275cfb30d036e3a1bd9477b08297815f07156b432a2724f8c08e9e841ef6bf7ba62ccf7df361f541e59024b42164bd35d7eef16da1f75ec WHIRLPOOL 651509487e6a86fd5f96a3ab55d31ecb13cf5d95d0079679665feb0c828e49186325f0670094fda439a73b0e3fbfad4899e32b66220bd3a55e85120ed85b5101
+DIST pam_skey-1.1.5.tar.gz 76963 SHA256 31f56a85780aa59326c7da891687af3820e997a80805dc47171175481f3762f7 SHA512 12817cedf15a3b2287982e4beab5d3b388239cc0a1e141e66e41759ddb2da7fb9dd0df12202dcc8140db0868c8df1a8d19d5859224179e2419ffefd691cb9834 WHIRLPOOL 835da66136cde2a19580c3e75a59cb9eadbbcb76dc542d1c96825438dff5c835d392c2232cae785c2999bc3e65772f06c91dea5fb03b945312a1a3a641647f1e
diff --git a/sys-auth/pam_skey/metadata.xml b/sys-auth/pam_skey/metadata.xml
new file mode 100644
index 000000000000..f6bcd7962899
--- /dev/null
+++ b/sys-auth/pam_skey/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pam</herd>
+ <maintainer>
+ <email>ulm@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="freshmeat">pam_skey</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild
new file mode 100644
index 000000000000..ee9b5510da86
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils pam autotools multilib readme.gentoo
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://dkorunic.net/tarballs/${P}.tar.gz
+ mirror://gentoo/${P}-patches-6.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+DOCS="README INSTALL"
+DOC_CONTENTS="To use the pam_skey module, you need to configure PAM
+ by adding a line like:
+ \n\nauth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so\n
+ \nto an appropriate place in the /etc/pam.d/system-auth file.
+ Consult the README and INSTALL files in /usr/share/doc/${PF}
+ for detailed instructions.
+ \n\nPlease note that calling this module from unprivileged
+ applications, e.g. screensavers, is not supported.
+ \n\nError checking has become stricter in pam_skey-1.1.5-r4;
+ errors returned from the underlying skey library when accessing
+ the S/Key data base will no longer be ignored.
+ Make sure that your PAM configuration is correct."
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+ epatch_user
+
+ cd autoconf
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die "mv failed"
+}
+
+src_configure() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC"
+}
+
+pkg_postinst() {
+ case ${REPLACING_VERSIONS} in
+ 1.1.[45]|1.1.5-r[123]) FORCE_PRINT_ELOG=1 ;;
+ esac
+ readme.gentoo_print_elog
+}