summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_u2f/pam_u2f-1.3.0.ebuild')
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-auth/pam_u2f/pam_u2f-1.3.0.ebuild b/sys-auth/pam_u2f/pam_u2f-1.3.0.ebuild
new file mode 100644
index 000000000000..c63693e01365
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic pam
+
+DESCRIPTION="PAM module for FIDO2 and U2F keys"
+HOMEPAGE="https://github.com/Yubico/pam-u2f"
+SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
+
+LICENSE="BSD ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libfido2:=
+ dev-libs/openssl:=
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
+ econf --with-pam-dir=$(getpam_mod_dir)
+}