summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild')
-rw-r--r--sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild b/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild
new file mode 100644
index 000000000000..ddde94c6da84
--- /dev/null
+++ b/sys-auth/ssh-import-id/ssh-import-id-5.11-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to securely retrieve an SSH public key and install it locally"
+HOMEPAGE="https://launchpad.net/ssh-import-id"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman usr/share/man/man1/ssh-import-id.1
+}