summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild')
-rw-r--r--sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild
index f47d13393d96..999f36b3d109 100644
--- a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild
+++ b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.4.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..11} )
+
inherit distutils-r1
DESCRIPTION="Utility to manage SSH public keys stored in LDAP"
@@ -23,25 +24,24 @@ LICENSE="MIT"
SLOT="0"
IUSE="schema"
-MY_CDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
>=dev-python/python-ldap-3.0[${PYTHON_USEDEP}]
virtual/logger"
-DEPEND="${MY_CDEPEND}
+DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pytest-describe[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
)"
-# We need to block previous net-misc/openssh packages
-# to avoid file collision on "/etc/openldap/schema/openssh-lpk.schema"
-RDEPEND="${MY_CDEPEND}
- schema? ( !net-misc/openssh[ldap(-)] )"
-
DOCS=( README.md CHANGELOG.adoc )
distutils_enable_tests pytest
+python_test() {
+ epytest -p pytest-describe
+}
+
python_install_all() {
distutils-r1_python_install_all