summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/ykpers/ykpers-1.16.2.ebuild')
-rw-r--r--sys-auth/ykpers/ykpers-1.16.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-auth/ykpers/ykpers-1.16.2.ebuild b/sys-auth/ykpers/ykpers-1.16.2.ebuild
new file mode 100644
index 000000000000..5f013c5faecf
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.16.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+src_install() {
+ DOCS=( doc/. AUTHORS ChangeLog NEWS README )
+ autotools-utils_src_install
+
+ use consolekit && udev_dorules *.rules
+}