summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/arcconf')
-rw-r--r--sys-block/arcconf/Manifest2
-rw-r--r--sys-block/arcconf/arcconf-1.2.20618.ebuild52
-rw-r--r--sys-block/arcconf/arcconf-1.7.21229.ebuild52
-rw-r--r--sys-block/arcconf/metadata.xml8
4 files changed, 114 insertions, 0 deletions
diff --git a/sys-block/arcconf/Manifest b/sys-block/arcconf/Manifest
new file mode 100644
index 000000000000..77411aee9528
--- /dev/null
+++ b/sys-block/arcconf/Manifest
@@ -0,0 +1,2 @@
+DIST arcconf_v1_2_20618.zip 11920300 SHA256 ce5fe8ad97065ec90844c9e7d3778036e22a013eb029db2d6bda3ff3024734e4 SHA512 e8415e929cd7a8c8bca33f0de29bdadf3595da911bc3c0984226e02e01e6f4e9c822363dd8aa093efd524eea19f0689784e0300403513a99ead14ac08c487efe WHIRLPOOL 95399b80233fc1b8eac6c98156ad4b5d3f9597fddb7f413b4498886f1aa96eb623195e84b7ba97c4f84e4e8e555847b1650dc0092b64fdcf43ed22fdc01b3d6b
+DIST arcconf_v1_7_21229.zip 11056748 SHA256 b9ec025ed6e7167551dc2a034b39999f5b43a3a6544e3e8989f75a89dd99c7b3 SHA512 66a56ea66b8011c1f8f431b25f95050e541311ee415a0d4bdee6ef6416ff499be41d275819694384f66e5a1401b467da82ab15ce7c3fe49e1e013370293cf63a WHIRLPOOL bd566063d986ca4558e79759c1cfa96fe5e8ba4f44f5bf7828c4840d9634db69f897619b75b7d39a0d2102b8abbe4ad565b89136145af128636c0a40e4c3ce71
diff --git a/sys-block/arcconf/arcconf-1.2.20618.ebuild b/sys-block/arcconf/arcconf-1.2.20618.ebuild
new file mode 100644
index 000000000000..4b599527576d
--- /dev/null
+++ b/sys-block/arcconf/arcconf-1.2.20618.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="http://www.adaptec.com/en-us/downloads/"
+SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_v${PV//./_}.zip"
+
+LICENSE="Adaptec-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+RESTRICT="mirror bindist"
+# RESTRICT="fetch"
+
+QA_PRESTRIPPED="/opt/bin/arcconf"
+
+S="${WORKDIR}"
+
+# Maintainer notes:
+# * When going via the $HOMEPAGE one has to agree to the Adaptec-EULA as
+# referenced above.
+# * Despite that EULA, one can download the package seemingly without
+# restrictions from $SRC_URI.
+# * It is therefore assumed that the binary is made available for public
+# download. Even more so since the archive does not contain a license
+# agreement stating otherwise.
+
+#pkg_nofetch() {
+# einfo "Upstream has implemented a mandatory clickthrough EULA for distfile download"
+# einfo "Please visit $HOMEPAGE, choose a controller (for example the Series 7, 7805)"
+# einfo "and then navigate to Storage Manager Downloads for the ARCCONF Command Line Utility."
+# einfo "And place $A in ${DISTDIR}"
+#}
+
+# Maintainer notes:
+# * FreeBSD binaries would be available for FreeBSD 7..9, which ones do we need?
+src_install() {
+ exeinto /opt/bin
+
+ if use amd64 ; then
+ doexe linux_x64/arcconf
+ else
+ doexe linux_x86/arcconf
+ fi
+}
diff --git a/sys-block/arcconf/arcconf-1.7.21229.ebuild b/sys-block/arcconf/arcconf-1.7.21229.ebuild
new file mode 100644
index 000000000000..e033902fa240
--- /dev/null
+++ b/sys-block/arcconf/arcconf-1.7.21229.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="http://www.adaptec.com/en-us/downloads/"
+SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_v${PV//./_}.zip"
+
+LICENSE="Adaptec-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+RESTRICT="mirror bindist"
+# RESTRICT="fetch"
+
+QA_PRESTRIPPED="/opt/bin/arcconf"
+
+S="${WORKDIR}"
+
+# Maintainer notes:
+# * When going via the $HOMEPAGE one has to agree to the Adaptec-EULA as
+# referenced above.
+# * Despite that EULA, one can download the package seemingly without
+# restrictions from $SRC_URI.
+# * It is therefore assumed that the binary is made available for public
+# download. Even more so since the archive does not contain a license
+# agreement stating otherwise.
+
+#pkg_nofetch() {
+# einfo "Upstream has implemented a mandatory clickthrough EULA for distfile download"
+# einfo "Please visit $HOMEPAGE, choose a controller (for example the Series 7, 7805)"
+# einfo "and then navigate to Storage Manager Downloads for the ARCCONF Command Line Utility."
+# einfo "And place $A in ${DISTDIR}"
+#}
+
+# Maintainer notes:
+# * FreeBSD binaries would be available for FreeBSD 7..9, which ones do we need?
+src_install() {
+ exeinto /opt/bin
+
+ if use amd64 ; then
+ doexe linux_x64/cmdline/arcconf
+ else
+ doexe linux_x86/cmdline/arcconf
+ fi
+}
diff --git a/sys-block/arcconf/metadata.xml b/sys-block/arcconf/metadata.xml
new file mode 100644
index 000000000000..5b2a5c55470b
--- /dev/null
+++ b/sys-block/arcconf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>