summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/nbd/nbd-3.9.1.ebuild')
-rw-r--r--sys-block/nbd/nbd-3.9.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-3.9.1.ebuild b/sys-block/nbd/nbd-3.9.1.ebuild
new file mode 100644
index 000000000000..3698be613bfe
--- /dev/null
+++ b/sys-block/nbd/nbd-3.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug zlib"
+
+RDEPEND=">=dev-libs/glib-2.0
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-lfs \
+ --enable-syslog \
+ $(use_enable debug) \
+ $(use_enable zlib gznbd)
+}