summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/rts_pstor')
-rw-r--r--sys-block/rts_pstor/Manifest1
-rw-r--r--sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch36
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-makefile.patch8
-rw-r--r--sys-block/rts_pstor/metadata.xml14
-rw-r--r--sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild38
5 files changed, 0 insertions, 97 deletions
diff --git a/sys-block/rts_pstor/Manifest b/sys-block/rts_pstor/Manifest
deleted file mode 100644
index 283cf39a5233..000000000000
--- a/sys-block/rts_pstor/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rts_pstor-1.10_p20160103.tar.gz 108102 BLAKE2B 9cbca345211f7c99c6d9cf71b0ed207a4c911569eee6c63bfbe15c094be08f64c4550f04d9df688969f43564b2ff6a91d5cc72b8ab281cfdffb6884688b354de SHA512 d802a52b1e2da447a218472e77ca6ecc56e3b3767e3eb8daf634152675171c79c86e3b5ca9654b67cf32f63740c347bf7ecee5a1d20eb1c15a3a2ad3e9774311
diff --git a/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch b/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch
deleted file mode 100644
index 7ea6ba6fd26b..000000000000
--- a/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/rtsx.h
-+++ b/rtsx.h
-@@ -81,6 +81,17 @@
- pci_get_domain_bus_and_slot(0, (bus), (devfn))
- #endif
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 0, 0)
-+static void do_gettimeofday(struct timeval *tv)
-+{
-+ struct timespec64 now;
-+
-+ ktime_get_real_ts64(&now);
-+ tv->tv_sec = now.tv_sec;
-+ tv->tv_usec = now.tv_nsec / 1000;
-+}
-+#endif
-+
- /*
- * macros for easy use
- */
---- a/rtsx.c
-+++ b/rtsx.c
-@@ -300,11 +300,13 @@
-
- .max_sectors = 240,
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
- /* merge commands... this seems to help performance, but
- * periodically someone should test to see which setting is more
- * optimal.
- */
- .use_clustering = 1,
-+#endif
-
-
- .emulated = 1,
diff --git a/sys-block/rts_pstor/files/rts_pstor-makefile.patch b/sys-block/rts_pstor/files/rts_pstor-makefile.patch
deleted file mode 100644
index dc12cd68f52b..000000000000
--- a/sys-block/rts_pstor/files/rts_pstor-makefile.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff -N -a -u1 a/Makefile b/Makefile
---- a/Makefile 2016-01-03 14:41:40.000000000 +0100
-+++ b/Makefile 2018-12-11 23:47:44.942218496 +0100
-@@ -36,3 +36,3 @@
- cp -f ./define.release ./define.h
-- make -C /lib/modules/$(shell uname -r)/build/ SUBDIRS=$(PWD) modules
-+ +make -C $(KERNELDIR) SUBDIRS=$(PWD) modules
- debug:
diff --git a/sys-block/rts_pstor/metadata.xml b/sys-block/rts_pstor/metadata.xml
deleted file mode 100644
index ab7993355b87..000000000000
--- a/sys-block/rts_pstor/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin.dummer@gmx.net</email>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription lang="en">
- PCI-E RTS5209 card reader driver for Linux.
- </longdescription>
-</pkgmetadata>
diff --git a/sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild b/sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild
deleted file mode 100644
index e9b31fc3584d..000000000000
--- a/sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-mod
-
-GIT_COMMIT="c8313abffe083ac63bf76d2cc90d3edf5b2d1188"
-
-DESCRIPTION="PCI-E RTS5209 card reader driver for Linux"
-HOMEPAGE="https://github.com/gexplorer/RTS5209-linux-driver"
-SRC_URI="https://github.com/gexplorer/RTS5209-linux-driver/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="virtual/linux-sources"
-PATCHES=(
- "${FILESDIR}/rts_pstor-makefile.patch"
- "${FILESDIR}/fix-compile-kernel-5.0.0.patch"
-)
-S="${WORKDIR}/RTS5209-linux-driver-${GIT_COMMIT}"
-
-MODULE_NAMES="rts_pstor(misc/drivers/scsi)"
-MODULESD_RTS_PSTOR_ADDITIONS=(
- "# when rts_pstor is installed, blacklist in-kernel driver rtsx_pci"
- "blacklist rtsx_pci"
-)
-BUILD_TARGETS="default"
-BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
-CONFIG_CHECK="~!MISC_RTSX_PCI"
-ERROR_MISC_RTSX_PCI="CONFIG_MISC_RTSX_PCI: The in-kernel driver rtsx_pci is configured, which may have the same functionality than this driver. To make sure that your kernel loads only rts_pstor, the rtsx_pci module will be blacklisted."
-
-pkg_postinst() {
- elog "This driver is based on code published by Realtek. There is a driver in the kernel named rtsx_pci which"
- elog "should be preferred over this driver - but on some hardware only this driver is functional and rtsx_pci is not."
-}