summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/whdd/whdd-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-block/whdd/whdd-9999.ebuild b/sys-block/whdd/whdd-9999.ebuild
index 381536f90efa..ccea158e179b 100644
--- a/sys-block/whdd/whdd-9999.ebuild
+++ b/sys-block/whdd/whdd-9999.ebuild
@@ -4,15 +4,21 @@
EAPI=6
-EGIT_REPO_URI="https://github.com/${PN}/${PN}"
-inherit git-r3
-
DESCRIPTION="Diagnostic and recovery tool for block devices"
HOMEPAGE="https://whdd.github.io"
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ inherit vcs-snapshot
+fi
+
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND="