summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/unetbootin')
-rw-r--r--sys-boot/unetbootin/Manifest2
-rw-r--r--sys-boot/unetbootin/files/unetbootin-581-desktop.patch24
-rw-r--r--sys-boot/unetbootin/metadata.xml11
-rw-r--r--sys-boot/unetbootin/unetbootin-608.ebuild89
-rw-r--r--sys-boot/unetbootin/unetbootin-619.ebuild89
5 files changed, 215 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
new file mode 100644
index 000000000000..a8af19bd9bcf
--- /dev/null
+++ b/sys-boot/unetbootin/Manifest
@@ -0,0 +1,2 @@
+DIST 619.tar.gz 22669784 SHA256 84bd5b29a46f61156868acf0d069c2c6b3ec13435dc11cc82f93e8c30523966f SHA512 81a02c0b7866f878139133562db745538f1f22fb90231a228792dccd3c5ff0c1c7cefc435b34cc14302b0d2b20e97342295fb65c7f28c220a637b1d52fa77e3c WHIRLPOOL 66a46933ea16b73f94d95080241103bac985694bc7b28e4213341aa9e6cb03f0fdf85bc19f9491b1ac97cba2ac83edfdba31965b9d138ef46bbf337bf03ded05
+DIST unetbootin-source-608.tar.gz 752043 SHA256 ce99c5f60b1f66da0ceb41859ce9198d96b3061b949b167fc952d3951b632080 SHA512 d164537c96845eb90ac5aae1fa0c553c9392d778696e4818760cb11f78341e6a3ea6a05f702678583c5d680dc8fb1348cdc2b2dfba9bebfdf793779c23611d16 WHIRLPOOL 56cc31e047c283b4f6ef639283c7e9a3e59332fb4f3b70baa279e973c19adc42a276074087b530a49cad41076cf29990c65323d805e0a7b4fccd37bdf1132649
diff --git a/sys-boot/unetbootin/files/unetbootin-581-desktop.patch b/sys-boot/unetbootin/files/unetbootin-581-desktop.patch
new file mode 100644
index 000000000000..ab1912b2e8a0
--- /dev/null
+++ b/sys-boot/unetbootin/files/unetbootin-581-desktop.patch
@@ -0,0 +1,24 @@
+ * unetbootin.desktop: error: key "GenericName[en_US]" in group "Desktop Entry"
+ is a localized key, but there is no non-localized key "GenericName"
+ * unetbootin.desktop: warning: value "Application;System;" for key
+ "Categories" in group "Desktop Entry" contains a deprecated value
+ * "Application"
+
+
+
+--- a/unetbootin.desktop
++++ b/unetbootin.desktop
+@@ -2,11 +2,11 @@
+ Version=1.0
+ Name=UNetbootin
+ Comment=Tool for creating Live USB drives
+-Categories=Application;System;
++Categories=System;
+ Exec=/usr/bin/unetbootin
+ Terminal=false
+ Type=Application
+ Name[en_US]=UNetbootin
+-GenericName[en_US]=UNetbootin
++GenericName=UNetbootin
+ Comment[en_US]=Tool for creating Live USB drives
+ Icon=unetbootin
diff --git a/sys-boot/unetbootin/metadata.xml b/sys-boot/unetbootin/metadata.xml
new file mode 100644
index 000000000000..d15162d662b7
--- /dev/null
+++ b/sys-boot/unetbootin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">unetbootin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-boot/unetbootin/unetbootin-608.ebuild b/sys-boot/unetbootin/unetbootin-608.ebuild
new file mode 100644
index 000000000000..695548c0e419
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-608.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS distributions"
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+S="${WORKDIR}"
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="
+ ${DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-581-desktop.patch"
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Make room between the last line of TRANSLATIONS and the next definition
+ sed -i \
+ -e '/^DEFINES/s|.*|\n&|g' \
+ ${PN}.pro || die
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+}
+
+src_configure() {
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use linguas_${lingua}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}
diff --git a/sys-boot/unetbootin/unetbootin-619.ebuild b/sys-boot/unetbootin/unetbootin-619.ebuild
new file mode 100644
index 000000000000..9fb9454c24ca
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-619.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="${HOMEPAGE}/archive/619.tar.gz -> ${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="
+ ${DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-581-desktop.patch"
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Make room between the last line of TRANSLATIONS and the next definition
+ sed -i \
+ -e '/^DEFINES/s|.*|\n&|g' \
+ ${PN}.pro || die
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+}
+
+src_configure() {
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use linguas_${lingua}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}