summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/mpich2/mpich2-1.5.ebuild')
-rw-r--r--sys-cluster/mpich2/mpich2-1.5.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.5.ebuild b/sys-cluster/mpich2/mpich2-1.5.ebuild
index e3e96c43c264..ffffb8966367 100644
--- a/sys-cluster/mpich2/mpich2-1.5.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -51,7 +51,7 @@ src_prepare() {
}
src_configure() {
- local c="--enable-shared"
+ local c="--enable-shared --disable-static"
# The configure statements can be somewhat confusing, as they
# don't all show up in the top level configure, however, they
@@ -109,4 +109,6 @@ src_install() {
if ! use doc; then
rm -rf "${D}"usr/share/doc/${PF}/www*
fi
+
+ find "${ED}" -name '*.la' -delete || die
}