summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/singularity/singularity-2.4.ebuild')
-rw-r--r--sys-cluster/singularity/singularity-2.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-cluster/singularity/singularity-2.4.ebuild b/sys-cluster/singularity/singularity-2.4.ebuild
new file mode 100644
index 000000000000..904c3ca6693e
--- /dev/null
+++ b/sys-cluster/singularity/singularity-2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="http://singularity.lbl.gov/"
+SRC_URI="https://github.com/${PN}ware/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="cctbx-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs +suid"
+
+src_prepare() {
+ default
+ # automake version hardcoding
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-userns \
+ $(usex suid "" "--disable-suid") \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ MAKEOPTS+=" -j1"
+ default
+ prune_libtool_files
+ dodoc ChangeLog CONTRIBUTORS.md CONTRIBUTING.md
+ use examples && dodoc -r examples
+}