summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 8ae03593af2f..553005830a8d 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -218,6 +218,11 @@ src_install() {
# Remove shared info pages
rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+
+ # gcore is part of ubin on freebsd
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ rm "${ED}"/usr/bin/gcore || die
+ fi
}
pkg_postinst() {