summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/icecream/icecream-1.0.0-r2.ebuild')
-rw-r--r--sys-devel/icecream/icecream-1.0.0-r2.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/sys-devel/icecream/icecream-1.0.0-r2.ebuild b/sys-devel/icecream/icecream-1.0.0-r2.ebuild
deleted file mode 100644
index e7cc21f4e7fe..000000000000
--- a/sys-devel/icecream/icecream-1.0.0-r2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="${P/icecream/icecc}"
-
-inherit user
-
-DESCRIPTION="Distributed compiling of C(++) code across several machines; based on distcc"
-HOMEPAGE="https://github.com/icecc/icecream"
-SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND="
- sys-libs/libcap-ng
-"
-RDEPEND="
- ${DEPEND}
- dev-util/shadowman
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${P}-libcap-ng.patch"
-)
-
-pkg_setup() {
- enewgroup icecream
- enewuser icecream -1 -1 /var/cache/icecream icecream
-}
-
-src_configure() {
- econf \
- --enable-shared --disable-static \
- --enable-clang-wrappers \
- --enable-clang-rewrite-includes
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-
- newconfd suse/sysconfig.icecream icecream
- newinitd "${FILESDIR}"/icecream-r2 icecream
-
- insinto /etc/logrotate.d
- newins suse/logrotate icecream
-
- insinto /usr/share/shadowman/tools
- newins - icecc <<<'/usr/libexec/icecc/bin'
-}
-
-pkg_prerm() {
- if [[ -z ${REPLACED_BY_VERSION} && ${ROOT} == / ]]; then
- eselect compiler-shadow remove icecc
- fi
-}
-
-pkg_postinst() {
- if [[ ${ROOT} == / ]]; then
- eselect compiler-shadow update icecc
- fi
-}