summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-4.0.0.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-4.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-4.0.0.ebuild b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
new file mode 100644
index 000000000000..d307094d751b
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/llvm-${PV/_/}.src
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}