summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-3.4.2-r100.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.4.2-r100.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-devel/llvm/llvm-3.4.2-r100.ebuild b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
index 5e73596754a7..0f5e951dbdcd 100644
--- a/sys-devel/llvm/llvm-3.4.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
@@ -84,16 +84,16 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
- epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
+ epatch "${FILESDIR}"/3.6.2/nodoctargz.patch
+ epatch "${FILESDIR}"/3.4.2/gentoo-install.patch
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+ epatch "${FILESDIR}"/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.4-gentoo-install.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_build_fix.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
+ epatch "${FILESDIR}"/3.4.2/clang/gentoo-install.patch
+ epatch "${FILESDIR}"/3.4.2/clang/darwin_build_fix.patch
+ epatch "${FILESDIR}"/3.9.0/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
fi