summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index ed5dd0b817a7..196984744a54 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -59,7 +59,11 @@ DEPEND="${RDEPEND}
<sys-libs/libcxx-$(ver_cut 1-3).9999
>=sys-devel/binutils-apple-5.1
)
- doc? ( dev-python/sphinx )
+ doc? ( $(python_gen_any_dep '
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ') )
+ !doc? ( ${PYTHON_DEPS} )
gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
@@ -77,6 +81,13 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+python_check_deps() {
+ use doc || return 0
+
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358