summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/Manifest3
-rw-r--r--sys-devel/patch/metadata.xml5
-rw-r--r--sys-devel/patch/patch-2.7.3.ebuild30
-rw-r--r--sys-devel/patch/patch-2.7.4.ebuild30
-rw-r--r--sys-devel/patch/patch-2.7.5.ebuild30
5 files changed, 98 insertions, 0 deletions
diff --git a/sys-devel/patch/Manifest b/sys-devel/patch/Manifest
new file mode 100644
index 000000000000..f45c742b5d25
--- /dev/null
+++ b/sys-devel/patch/Manifest
@@ -0,0 +1,3 @@
+DIST patch-2.7.3.tar.xz 684764 SHA256 d09022de9d629561bf4dad44625ef4b1ead15178b210412113531730cdb6f19d SHA512 8d2e3010cfb3283913edb87cbf8d3c474811dc0d288fcb6b87b8ce62296ae95c16dd3b59f21345905d4ffbc572d0be985612eebf90f0e9ee390ca53613402836 WHIRLPOOL 7b4e5471e22c24d97ebac94939582d5d3d311f057e97b43f39def297b7c2db723f5558d66d10c3b289caea241b931dea49beabfe0ec03c0c6d0f91bc526ad52c
+DIST patch-2.7.4.tar.xz 714392 SHA256 0eacbb07ce106fe4dcbfbe6c052e55b50bf3df8e1bb16228c9da77b6659ff109 SHA512 7842ad925c6223b1e106844d403a66151fd511a51bf2c78f3c15aa15f5e923f9b58d139bc098aca7c7c6d07e78c01dba729a7e85e93c1c7d18f3150314be0a6f WHIRLPOOL 71c5643345b6c573afe59b13a9c69c0076b38bbd3448220f645b4bb0fc629dc598e37242770de52fa4f1fb949a90375e1b9dca2d43188342562385ad77512d84
+DIST patch-2.7.5.tar.xz 727704 SHA256 fd95153655d6b95567e623843a0e77b81612d502ecf78a489a4aed7867caa299 SHA512 6620ac8101f60c0b456ce339fa5e371f40be0b391e2e9728f34f3625f9907e516de61dac2f91bc76e6fd28a9bd1224efc3ba827cfaa606d857730c1af4195a0f WHIRLPOOL 27e209cd99b0e3366c7e094e54581510fb3018202fc79d6a906e14e87efae1b7b7548fcafb70af6f5db59f08237fd0f5363789d719ff3452925bd99dc41a9cdb
diff --git a/sys-devel/patch/metadata.xml b/sys-devel/patch/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-devel/patch/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-devel/patch/patch-2.7.3.ebuild b/sys-devel/patch/patch-2.7.3.ebuild
new file mode 100644
index 000000000000..7f8abcef7a61
--- /dev/null
+++ b/sys-devel/patch/patch-2.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static test xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Do not let $ED mess up the search for `ed` 470210.
+ ac_cv_path_ED=$(type -P ed) \
+ econf \
+ $(use_enable xattr) \
+ --program-prefix="$(use userland_BSD && echo g)"
+}
diff --git a/sys-devel/patch/patch-2.7.4.ebuild b/sys-devel/patch/patch-2.7.4.ebuild
new file mode 100644
index 000000000000..a7aab5abe302
--- /dev/null
+++ b/sys-devel/patch/patch-2.7.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static test xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Do not let $ED mess up the search for `ed` 470210.
+ ac_cv_path_ED=$(type -P ed) \
+ econf \
+ $(use_enable xattr) \
+ --program-prefix="$(use userland_BSD && echo g)"
+}
diff --git a/sys-devel/patch/patch-2.7.5.ebuild b/sys-devel/patch/patch-2.7.5.ebuild
new file mode 100644
index 000000000000..d484a508ccf4
--- /dev/null
+++ b/sys-devel/patch/patch-2.7.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static test xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Do not let $ED mess up the search for `ed` 470210.
+ ac_cv_path_ED=$(type -P ed) \
+ econf \
+ $(use_enable xattr) \
+ --program-prefix="$(use userland_BSD && echo g)"
+}