summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/sparse/sparse-0.6.3.ebuild')
-rw-r--r--sys-devel/sparse/sparse-0.6.3.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/sys-devel/sparse/sparse-0.6.3.ebuild b/sys-devel/sparse/sparse-0.6.3.ebuild
deleted file mode 100644
index 0c2099d4c278..000000000000
--- a/sys-devel/sparse/sparse-0.6.3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit llvm toolchain-funcs
-
-DESCRIPTION="C semantic parser"
-HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
-else
- SRC_URI="https://www.kernel.org/pub/software/devel/${PN}/dist/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="gtk llvm sqlite test xml"
-RESTRICT="!test? ( test )"
-
-LLVM_MAX_SLOT=10
-
-RDEPEND="gtk? ( x11-libs/gtk+:2 )
- llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
- sqlite? ( dev-db/sqlite:= )
- xml? ( dev-libs/libxml2 )"
-DEPEND="${RDEPEND}
- gtk? ( virtual/pkgconfig )
- xml? ( virtual/pkgconfig )"
-
-pkg_setup() {
- use llvm && llvm_pkg_setup
-}
-
-_emake() {
- # Makefile does not allow for an easy override of flags.
- # Collect them here and override default phases.
- emake \
- CC="$(tc-getCC)" \
- LD="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- CFLAGS="${CFLAGS}" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- \
- HAVE_GTK=$(usex gtk) \
- HAVE_LLVM=$(usex llvm) \
- HAVE_SQLITE=$(usex sqlite) \
- HAVE_LIBXML=$(usex xml) \
- \
- V=1 \
- PREFIX="${EPREFIX}/usr" \
- \
- "$@"
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake check
-}
-
-src_install() {
- _emake DESTDIR="${D}" install
-
- dodoc FAQ README
-}