summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/qconf/Manifest1
-rw-r--r--sys-devel/qconf/qconf-2.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/qconf/Manifest b/sys-devel/qconf/Manifest
index adfa77ac7b5a..aff4564c5656 100644
--- a/sys-devel/qconf/Manifest
+++ b/sys-devel/qconf/Manifest
@@ -1,2 +1,3 @@
DIST qconf-1.5_pre717.tar.bz2 42010 SHA256 16ece50ac3f9533cf05d7abb44a025503ef8a3ea985fb70ba4c2224f27fdf903 SHA512 c3dcabe1d8aeaf1cabacd6e2e37dcbaaea85b28ec212fa2a0a48cfeec6b0bddea35eb2bd1828a5985daad3f2ad5e2cb6edaa2fbf3fda54b9fd3cfa64d5d3aa99 WHIRLPOOL e351cc97b30b1d166d8a6cf6327833c49a95c55c68ae50959e2b0fd0d12b86ade638348cc816e665d01692abf3ea0f8721400ba89243badd2c8cda0380f2d1e6
DIST qconf-2.0.tar.bz2 50507 SHA256 772022c9757530c192d3bb1d31c4d6076b3464a8395dc06d3019923c44f999f2 SHA512 8820dfe191149b8bf7aa2cd631a6c4900b821c30817c6bffcf79734271c47165daceef11507690d495881c8dc8d19f8dec441c7adeb2a3e36b355b66b4f5c43a WHIRLPOOL facc512a3df046e131825a45afc928b76d8c87446b8d4161695165e6551cebfb586497b2cad3c69a9a75afa0791b9c915e6f7019ead9925d867c01d7bd573f09
+DIST qconf-2.3.tar.xz 51848 SHA256 d189dcf5589fe7d8ca53b963ba8bd33b91c4a75d1e7d863544174e6b7d69f581 SHA512 27a532cb52067707a3e04a40260bb0f42e40adff4a643d2f048832356de58271e4051c9cb810e6fffd4b4e45dba483ed65aec062506053caa262ac03b3ec6253 WHIRLPOOL 6fc386321d4a9bbb12254d427355feaadc90c4b66dfdd0d69a635c15ed72c481aede18c506b9b15260de448931bbbbec6c3a59d374c49491e997d6f52a33ea62
diff --git a/sys-devel/qconf/qconf-2.3.ebuild b/sys-devel/qconf/qconf-2.3.ebuild
new file mode 100644
index 000000000000..11d8d88cd3f0
--- /dev/null
+++ b/sys-devel/qconf/qconf-2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="https://github.com/psi-plus/qconf"
+SRC_URI="http://psi-im.org/files/qconf/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="qt4 +qt5"
+
+# There is no one to one match to autotools-based configure
+QA_CONFIGURE_OPTIONS=".*"
+
+RDEPEND="
+ qt4? ( dev-qt/qtcore:4 )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+ )
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+src_configure() {
+ use qt4 && QTVERSION=4
+ use qt5 && QTVERSION=5
+ econf \
+ --qtselect="${QTVERSION}" \
+ --extraconf=QMAKE_STRIP= \
+ --verbose || die
+
+ # just to set all the Gentoo toolchain flags
+ eqmake${QTVERSION}
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}