summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cachefilesd/files/0.10.1-makefile.patch')
-rw-r--r--sys-fs/cachefilesd/files/0.10.1-makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-fs/cachefilesd/files/0.10.1-makefile.patch b/sys-fs/cachefilesd/files/0.10.1-makefile.patch
new file mode 100644
index 000000000000..af029c9293a3
--- /dev/null
+++ b/sys-fs/cachefilesd/files/0.10.1-makefile.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 15a8445..d650f47 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,3 @@
+-CFLAGS := -g -O2 -Wall
+ INSTALL := install
+ DESTDIR :=
+ BUILDFOR :=
+@@ -21,7 +20,10 @@ endif
+ #
+ all: cachefilesd
+
+-cachefilesd: cachefilesd.c Makefile
++cachefilesd.o: cachefilesd.c
++ $(CC) $(CFLAGS) -c $<
++
++cachefilesd: cachefilesd.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ #