summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/davl/davl-1.2.4-r2.ebuild')
-rw-r--r--sys-fs/davl/davl-1.2.4-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/davl/davl-1.2.4-r2.ebuild b/sys-fs/davl/davl-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..75b61c72361c
--- /dev/null
+++ b/sys-fs/davl/davl-1.2.4-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Visualizes the fragmentation status of ext2/3 filesystems"
+HOMEPAGE="http://davl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6:2"
+DEPEND="${RDEPEND}
+ >=sys-fs/e2fsprogs-1.41.7-r1
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.1-asneeded.patch
+ "${FILESDIR}"/${P}-fragment.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin src/{cdavl/cdavl,gdavl/gdavl}
+ dodoc README
+ doman doc/*.8
+}