summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/fatsort/fatsort-1.5.0.ebuild')
-rw-r--r--sys-fs/fatsort/fatsort-1.5.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sys-fs/fatsort/fatsort-1.5.0.ebuild b/sys-fs/fatsort/fatsort-1.5.0.ebuild
deleted file mode 100644
index d677a51ab6d2..000000000000
--- a/sys-fs/fatsort/fatsort-1.5.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-SVN_REV=456
-MY_P=${P}.${SVN_REV}
-
-DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
-HOMEPAGE="http://fatsort.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.5.0-gcc10.patch"
-)
-
-src_prepare() {
- default
-
- sed -i -e '/^\(MANDIR=\|SBINDIR=\)/s|/usr/local|/usr|' \
- $(find ./ -name Makefile) || die
-}
-
-src_compile() {
- emake CC=$(tc-getCC) LD=$(tc-getCC) \
- CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- DESTDIR="${D}"
-}
-
-src_test() {
- # Tests require root permissions and mounting filesystems which does
- # not work inside the ebuild environment
- true
-}