summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch')
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch b/sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch
new file mode 100644
index 000000000000..19573fe6eee6
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch
@@ -0,0 +1,17 @@
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -90,11 +90,12 @@ OPTFLAGS = -O2 -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
+ -Wp,-D_FORTIFY_SOURCE=2 $(STACKPROT) \
+ --param=ssp-buffer-size=4
+
+-CFLAGS = $(OPTFLAGS) -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\"
++CFLAGS ?= $(OPTFLAGS)
++CFLAGS += -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\"
+ BIN_CFLAGS = -fPIE -DPIE
+ LIB_CFLAGS = -fPIC
+ SHARED_FLAGS = -shared
+-LDFLAGS = -Wl,-z,relro -Wl,-z,now
++LDFLAGS += -Wl,-z,relro -Wl,-z,now
+ BIN_LDFLAGS = -pie
+
+ # Check whether a function with name $1 has been declared in header file $2.