summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild')
-rw-r--r--sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild b/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild
new file mode 100644
index 000000000000..51eb987cba00
--- /dev/null
+++ b/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Small defragmentation tool for reiserfs"
+HOMEPAGE="https://github.com/i-rinat/reiserfs-defrag"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc ChangeLog README.md
+}
+
+pkg_postinst() {
+ ewarn "Defragmentation should be done OFFLINE only! You MUST unmount your reiserfs partition before starting ${PN}"
+}