summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/safecopy')
-rw-r--r--sys-fs/safecopy/Manifest1
-rw-r--r--sys-fs/safecopy/metadata.xml12
-rw-r--r--sys-fs/safecopy/safecopy-1.7.ebuild48
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-fs/safecopy/Manifest b/sys-fs/safecopy/Manifest
new file mode 100644
index 000000000000..2e50e7f6425e
--- /dev/null
+++ b/sys-fs/safecopy/Manifest
@@ -0,0 +1 @@
+DIST safecopy-1.7.tar.gz 398465 SHA256 42fbed5d4764020eb0f34d95e97a0e14e62d801c3ef80f89bd497d94d39cc4fd SHA512 ecba54ecc0e0dc13dd6339f8c8dc311fc3ad41ef23318c1aa2a7f6bb7f1529389bedf7b58ea72486c083d39032a6e4a775e5a555a1ff96c669fa7fbd6c1fb868 WHIRLPOOL e71dd8c5db77a53a1cb088d964f1496581ef3ca7d534413f5bd20a3939b32fcab869aaaf05395bbcfd7289982be1c2e4065a55470f5a852b8c552dd8578cd09f
diff --git a/sys-fs/safecopy/metadata.xml b/sys-fs/safecopy/metadata.xml
new file mode 100644
index 000000000000..95aac75c6a48
--- /dev/null
+++ b/sys-fs/safecopy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>safecopy is a data recovery tool which tries to extract as much data as possible from a problematic (i.e. damaged sectors) source - like floppy drives, hard disk partitions, CDs, tape devices, ..., where other tools like dd would fail due to I/O errors.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">safecopy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/safecopy/safecopy-1.7.ebuild b/sys-fs/safecopy/safecopy-1.7.ebuild
new file mode 100644
index 000000000000..7a1672e93a3c
--- /dev/null
+++ b/sys-fs/safecopy/safecopy-1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="Data recovery tool to fault-tolerantly extract data from damaged (io-errors) devices or files"
+HOMEPAGE="http://safecopy.sourceforge.net"
+SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=""
+
+DOCS=( README )
+
+src_prepare() {
+ base_src_prepare
+ sed -e 's:bin/sh:bin/bash:' \
+ -i "${S}"/test/test.sh || die
+}
+
+src_configure() {
+ econf
+ if use test; then
+ cd "${S}"/simulator
+ econf
+ fi
+}
+
+src_compile() {
+ emake
+ if use test; then
+ cd "${S}"/simulator
+ emake
+ fi
+}
+
+src_test() {
+ cd "${S}"/test
+ ./test.sh || die
+}