summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild
index 9d62b792264c..a902386ca81f 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils toolchain-funcs
+
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Tool for creating compressed filesystem type squashfs"
HOMEPAGE="http://squashfs.sourceforge.net"
@@ -34,6 +35,10 @@ src_prepare() {
use10() { usex $1 1 2 ; }
src_configure() {
+ # restore GNU89 inline semantics to
+ # emit function symbols, bug 595290
+ append-cflags -std=gnu89
+
# set up make command line variables in EMAKE_SQUASHFS_CONF
EMAKE_SQUASHFS_CONF=(
LZMA_XZ_SUPPORT=$(use10 lzma)