summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse-common/Manifest1
-rw-r--r--sys-fs/fuse-common/fuse-common-3.2.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/fuse-common/Manifest b/sys-fs/fuse-common/Manifest
index 4e932706581b..02f084e433b4 100644
--- a/sys-fs/fuse-common/Manifest
+++ b/sys-fs/fuse-common/Manifest
@@ -1 +1,2 @@
DIST fuse-3.2.1.tar.xz 1042772 BLAKE2B fe7dccc3b791a3b549815f5015a993c29d9481742a88b0291a03b39b95c0acb709969bdc0f6fbea5a48d0bb97bc362ad351b719d77a4f9f630825308f3fb1913 SHA512 edf08711fa02c40b9d3507c99e0b1bfd7208edc1494888c4e2bad92b621eb5c43c4cb31474d2d3bb1edaaf9cd876f3407cdb00a1bdcf61a0b74c876d3707518e
+DIST fuse-3.2.2.tar.xz 1187816 BLAKE2B 4cda342ded747a92f31417c32006e202398555d2112134f403addd1f2ef896ed46e1082a13437e657795ae93b67fb2692746b759b9efb3bd8c70857623ca1af6 SHA512 234256ed8e9e277557775d34b0aa77f3b0a3c40a715e52db1437f2ffd2a7d8eda2e12ef35963a918b3310f7244bba9b3755003a25b98ea6d29b6d4b322cddec7
diff --git a/sys-fs/fuse-common/fuse-common-3.2.2.ebuild b/sys-fs/fuse-common/fuse-common-3.2.2.ebuild
new file mode 100644
index 000000000000..574c6ffdefaa
--- /dev/null
+++ b/sys-fs/fuse-common/fuse-common-3.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson udev flag-o-matic
+
+DESCRIPTION="Common files for multiple slots of sys-fs/fuse"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="!<sys-fs/fuse-2.9.7-r1:0"
+
+S=${WORKDIR}/fuse-${PV}
+
+# tests run in sys-fs/fuse
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # lto not supported yet -- https://github.com/libfuse/libfuse/issues/198
+ filter-flags -flto*
+}
+
+src_install() {
+ newsbin "${BUILD_DIR}"/util/mount.fuse3 mount.fuse
+ doman doc/mount.fuse.8
+
+ udev_newrules util/udev.rules 99-fuse.rules
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ insinto /etc
+ doins util/fuse.conf
+}