summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.9.10.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.9.10.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.9.10.ebuild b/sys-kernel/ck-sources/ck-sources-4.9.10.ebuild
index 72d3a2906e9d..c9184a2f56ef 100644
--- a/sys-kernel/ck-sources/ck-sources-4.9.10.ebuild
+++ b/sys-kernel/ck-sources/ck-sources-4.9.10.ebuild
@@ -16,10 +16,13 @@ K_GENPATCHES_VER="12"
K_SECURITY_UNSUPPORTED="1"
K_DEBLOB_AVAILABLE="1"
-inherit kernel-2
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
detect_version
detect_arch
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
DESCRIPTION="Con Kolivas' high performance patchset and Gentoo's genpatches for Linux ${K_BRANCH_ID}"
@@ -78,6 +81,11 @@ UNIPATCH_STRICTORDER="yes"
K_EXP_GENPATCHES_LIST="5010_*.patch*"
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}
+
src_prepare() {
#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------