summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/gentoo-kernel/gentoo-kernel-5.7.13.ebuild')
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.7.13.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.13.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.13.ebuild
index f0988ba69fb4..4d3cb4225691 100644
--- a/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.13.ebuild
+++ b/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.13.ebuild
@@ -20,6 +20,10 @@ SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.x
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
-> kernel-x86_64-fedora.config.${CONFIG_VER}
)
+ arm64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64-fedora.config
+ -> kernel-aarch64.config.${CONFIG_VER}
+ )
x86? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
-> kernel-i686-fedora.config.${CONFIG_VER}
@@ -30,8 +34,7 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="debug"
REQUIRED_USE="
- arm? ( savedconfig )
- arm64? ( savedconfig )"
+ arm? ( savedconfig )"
RDEPEND="
!sys-kernel/vanilla-kernel:${SLOT}
@@ -58,12 +61,15 @@ src_prepare() {
amd64)
cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64.config.${CONFIG_VER}" .config || die
+ ;;
x86)
cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
;;
- arm|arm64)
- return
- ;;
*)
die "Unsupported arch ${ARCH}"
;;