summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index 0b15091c69b4..1056574b8066 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit savedconfig
if [[ ${PV} == 99999999* ]]; then
- inherit git-2
+ inherit git-r3
SRC_URI=""
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
KEYWORDS=""
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ GIT_COMMIT=""
+ SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -67,7 +68,7 @@ QA_PREBUILT="lib/firmware/*"
src_unpack() {
if [[ ${PV} == 99999999* ]]; then
- git-2_src_unpack
+ git-r3_src_unpack
else
default
# rename directory from git snapshot tarball
@@ -76,6 +77,7 @@ src_unpack() {
}
src_prepare() {
+ default
echo "# Remove files that shall not be installed from this list." > ${PN}.conf
find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf