summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch')
-rw-r--r--sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch b/sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch
new file mode 100644
index 000000000000..7164103f8a7d
--- /dev/null
+++ b/sys-libs/argp-standalone/files/argp-standalone-1.3-shared.patch
@@ -0,0 +1,49 @@
+--- a/Makefile.am 2009-05-28 15:19:50.000000000 +0200
++++ b/Makefile.am 2009-05-28 15:30:57.000000000 +0200
+@@ -21,20 +21,20 @@
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = . testsuite
+
+-LIBOBJS = @LIBOBJS@
++LTLIBOBJS = @LTLIBOBJS@
+
+-noinst_LIBRARIES = libargp.a
++lib_LTLIBRARIES = libargp.la
+ noinst_PROGRAMS = argp-test
+ noinst_HEADERS = argp.h argp-fmtstream.h argp-namefrob.h # argp-comp.h
+
+ EXTRA_DIST = mempcpy.c strchrnul.c strndup.c Versions
+
+ # Leaves out argp-fs-xinl.c and argp-xinl.c
+-libargp_a_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
++libargp_la_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
+ argp-help.c argp-parse.c argp-pv.c \
+ argp-pvh.c
+
+-libargp_a_LIBADD = $(LIBOBJS)
++libargp_la_LIBADD = $(LTLIBOBJS)
+
+-argp_test_LDADD = libargp.a
++argp_test_LDADD = libargp.la
+
+--- a/configure.ac 2009-05-28 15:20:01.000000000 +0200
++++ b/configure.ac 2009-05-28 15:21:06.000000000 +0200
+@@ -17,6 +17,7 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
+ AM_PROG_CC_STDC
++AC_PROG_LIBTOOL
+
+ if test "x$am_cv_prog_cc_stdc" = xno ; then
+ AC_ERROR([the C compiler doesn't handle ANSI-C])
+--- a/testsuite/Makefile.am 2009-05-28 15:21:33.000000000 +0200
++++ b/testsuite/Makefile.am 2009-05-28 15:21:41.000000000 +0200
+@@ -5,7 +5,7 @@
+
+ noinst_PROGRAMS = $(TS_PROGS) ex1 ex3 ex4
+
+-LDADD = ../libargp.a
++LDADD = -L../.libs -largp
+
+ EXTRA_DIST = $(TS_SH) run-tests
+ CLEANFILES = test.out