summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/db-4.8.30-r2.ebuild16
-rw-r--r--sys-libs/db/db-5.3.28-r2.ebuild16
-rw-r--r--sys-libs/db/db-6.0.30-r1.ebuild16
-rw-r--r--sys-libs/db/db-6.0.35.ebuild16
-rw-r--r--sys-libs/db/db-6.1.26.ebuild16
5 files changed, 30 insertions, 50 deletions
diff --git a/sys-libs/db/db-4.8.30-r2.ebuild b/sys-libs/db/db-4.8.30-r2.ebuild
index abb91dec4812..e556706b2c02 100644
--- a/sys-libs/db/db-4.8.30-r2.ebuild
+++ b/sys-libs/db/db-4.8.30-r2.ebuild
@@ -88,16 +88,6 @@ src_prepare() {
-e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure || die
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -110,6 +100,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-5.3.28-r2.ebuild b/sys-libs/db/db-5.3.28-r2.ebuild
index fa3f8d6be49f..937d045c4164 100644
--- a/sys-libs/db/db-5.3.28-r2.ebuild
+++ b/sys-libs/db/db-5.3.28-r2.ebuild
@@ -103,16 +103,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -125,6 +115,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-6.0.30-r1.ebuild b/sys-libs/db/db-6.0.30-r1.ebuild
index 64433d238606..8192bec05d4e 100644
--- a/sys-libs/db/db-6.0.30-r1.ebuild
+++ b/sys-libs/db/db-6.0.30-r1.ebuild
@@ -104,16 +104,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -126,6 +116,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-6.0.35.ebuild b/sys-libs/db/db-6.0.35.ebuild
index 357f5ac8131d..6fcfe907e32b 100644
--- a/sys-libs/db/db-6.0.35.ebuild
+++ b/sys-libs/db/db-6.0.35.ebuild
@@ -104,16 +104,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -126,6 +116,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(
diff --git a/sys-libs/db/db-6.1.26.ebuild b/sys-libs/db/db-6.1.26.ebuild
index 22cf36f227a6..4e9a232205de 100644
--- a/sys-libs/db/db-6.1.26.ebuild
+++ b/sys-libs/db/db-6.1.26.ebuild
@@ -104,16 +104,6 @@ src_prepare() {
done
}
-src_configure() {
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- multilib-minimal_src_configure
-}
-
multilib_src_configure() {
local myconf=()
@@ -126,6 +116,12 @@ multilib_src_configure() {
is-flagq -O[s123] || append-flags -O2
fi
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU ; then
+ append-ldflags -Wl,--default-symver
+ fi
+
# use `set` here since the java opts will contain whitespace
if multilib_is_native_abi && use java ; then
myconf+=(