summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/efivar')
-rw-r--r--sys-libs/efivar/efivar-31.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/efivar/efivar-31.ebuild b/sys-libs/efivar/efivar-31.ebuild
index 3dbf6c4f5c67..10cdb3688a7f 100644
--- a/sys-libs/efivar/efivar-31.ebuild
+++ b/sys-libs/efivar/efivar-31.ebuild
@@ -28,4 +28,9 @@ src_configure() {
tc-ld-disable-gold
export libdir="/usr/$(get_libdir)"
unset LIBS # Bug 562004
+
+ if [[ -n ${GCC_SPECS} ]]; then
+ # The environment overrides the command line.
+ GCC_SPECS+=":${S}/gcc.specs"
+ fi
}