summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/fortify-headers/fortify-headers-9999.ebuild')
-rw-r--r--sys-libs/fortify-headers/fortify-headers-9999.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/sys-libs/fortify-headers/fortify-headers-9999.ebuild b/sys-libs/fortify-headers/fortify-headers-9999.ebuild
index 5347e1e57683..978f5b027268 100644
--- a/sys-libs/fortify-headers/fortify-headers-9999.ebuild
+++ b/sys-libs/fortify-headers/fortify-headers-9999.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone implementation of fortify source"
+HOMEPAGE="https://github.com/jvoisin/fortify-headers"
if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
+ EGIT_REPO_URI="https://github.com/jvoisin/fortify-headers"
inherit git-r3
else
- #SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
- SRC_URI="https://dl.2f30.org/releases/${P}.tar.gz"
+ FORTIFY_COMMIT=""
+ SRC_URI="https://github.com/jvoisin/fortify-headers/archive/${FORTIFY_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
fi
-DESCRIPTION="A standalone implementation of fortify source"
-HOMEPAGE="http://git.2f30.org/fortify-headers/"
-
LICENSE="ISC"
SLOT="0"
@@ -30,6 +32,10 @@ src_compile() {
:;
}
+src_test() {
+ emake -C tests CC="$(tc-getCC)"
+}
+
src_install() {
export DESTDIR="${ED}"
default