summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/kpmcore/kpmcore-4.2.0.ebuild')
-rw-r--r--sys-libs/kpmcore/kpmcore-4.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/kpmcore/kpmcore-4.2.0.ebuild b/sys-libs/kpmcore/kpmcore-4.2.0.ebuild
new file mode 100644
index 000000000000..4f02cda2f965
--- /dev/null
+++ b/sys-libs/kpmcore/kpmcore-4.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_NONGUI="true"
+KFMIN=5.74.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://kde.org/applications/en/partitionmanager"
+
+LICENSE="GPL-3"
+SLOT="5/10"
+IUSE=""
+
+BDEPEND="
+ >=kde-frameworks/kauth-${KFMIN}:5
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=sys-apps/util-linux-2.33.2
+ sys-auth/polkit-qt
+"
+RDEPEND="${DEPEND}"
+
+# bug 689468, tests need polkit etc.
+RESTRICT+=" test"