summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libosinfo/libosinfo-0.3.0-r1.ebuild')
-rw-r--r--sys-libs/libosinfo/libosinfo-0.3.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-libs/libosinfo/libosinfo-0.3.0-r1.ebuild b/sys-libs/libosinfo/libosinfo-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..8bf6eacb3788
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-0.3.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 udev vala xdg-utils
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="http://libosinfo.org/"
+SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE="+introspection +vala test"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2:2
+ >=dev-libs/libxslt-1.0.0:=
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.42:2.4
+ sys-apps/hwids
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ xdg_environment_reset
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable test tests) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --disable-coverage
+}