summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libservicelog/libservicelog-1.0.1.ebuild')
-rw-r--r--sys-libs/libservicelog/libservicelog-1.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/libservicelog/libservicelog-1.0.1.ebuild b/sys-libs/libservicelog/libservicelog-1.0.1.ebuild
new file mode 100644
index 000000000000..d8da34a1eeaa
--- /dev/null
+++ b/sys-libs/libservicelog/libservicelog-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="Provides a library for logging service-related events"
+SRC_URI="mirror://sourceforge/linux-diag/${P}.tar.gz"
+HOMEPAGE="http://linux-diag.sourceforge.net/servicelog/"
+
+SLOT="0"
+LICENSE="IBM"
+KEYWORDS="ppc ppc64"
+IUSE=""
+
+DEPEND="dev-db/sqlite"
+
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/libservicelog-1.0.1.patch
+
+ eautoreconf
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog || die
+}